Converting DSL-AC68U to RT-AC68U for use as AiMesh Node – Solved

Home Forums Wireless Routers & Modems ASUS Converting DSL-AC68U to RT-AC68U for use as AiMesh Node – Solved

  • This topic has 164 replies, 11 voices, and was last updated 2 weeks, 1 day ago by Patryk PaboPatryk Pabo.
Viewing 15 posts - 1 through 15 (of 165 total)
  • Author
    Posts
  • #1873
    Six
    Participant
    • Posts 54
    • UKTechHub Regular

    I’m sure there were a series of posts on the old forum about hacking a DSL-AC68U to make it into an RT-AC68U. Sadly those posts are lost and not cached on Google searches.

    I believe that RT firmware can be loaded using the recovery process. Does the standard Asus RT firmware work on the DSL or is a Merlin version needed.

    The aim is to use the DSL as an AiMesh node, hence the conversion to being an RT. I believe that after loading the RT firmware the DSL needs it’s ID changing. Does anyone have the commands needed to change the ID?

    Thanks in advance.

    • This topic was modified 1 year, 9 months ago by Six.
    #1874
    UK Sentinel
    Moderator
    • Posts 2181
    • UKTechHub Skipper

    Enjoy ;) Either ASUSWRT or RMerlin firmware will work.

    Note: backup original config as this maybe needed to convert back to DSL-AC68U if needed.

    RMerlin (ASUSWRT-Merlin) Firmware and the ASUS DSL-AC68U (PPPoE)

    Regarding Product ID: 2 options both of which I have never tried, and if you try, at your risk ;-)

    1) Backup config from DSL-AC68U after it has been flashed. then via an hex editor, change router name to RT-AC1900, so new name has same number of character as original name and then load .cfg file to router and see if this does the trick ?

    OR

    2) Telnet to Flashed DSL-AC68U running RT Firmware (RMerlin is best and change variables  as appropriate below)

    Code:
    nvram set cfg_device_list=”<RT-AC68U>192.168.1.1>38:2C:4A:CA:D1:B8>0″
    nvram set dms_friendly_name=”RT-AC68U-D1B8″
    nvram set computer_name=”RT-AC68U-D1B8″
    nvram set productid=”RT-AC68U”
    nvram set lld2d_hostname=”RT-AC68U”
    nvram set asus_device_list=”<3>RT-AC68U>192.168.1.1>38:2C:4A:CA
    :D1:B8>0>asus>255.255.255.0>1″
    nvram set wps_modelnum=”RT-AC68U”
    nvram set daapd_friendly_name=”RT-AC68U-D1B8″
    nvram set wps_device_name=”RT-AC68U”
    nvram set odmpid=”RT-AC68U”

    Let us know how this goes and good luck?

    In a completely sane world, madness is the only freedom (J.G.Ballard).

    #1875
    Six
    Participant
    • Posts 54
    • UKTechHub Regular

    Trying to post a guide to what I’ve done so far, keep hitting a xxxxx protection issue.

    This post edited by UK Sentinel (Admin) to remove security related detail

    • This reply was modified 1 year, 9 months ago by UK Sentinel. Reason: Security Detailed removed
    #1876
    Six
    Participant
    • Posts 54
    • UKTechHub Regular

    Thanks for the above, I found the same list of commands after a huge amount of digging elsewhere.

    Need to confirm that router can find the AiMesh Node later on (main router currently in use).

    Part One:

    Steps taken so far:

    Download and unzip latest RT-AC68U firmware from asus.com

    Download, unzip and install Recovery Tool from asus.com

    Factory resest DSL-AC68U

    Put DSL-AC68U into Recovery Mode by holding reset while powering on and waiting for flashing power LED.

    Connect to DSL-AC68U with ethernet cable and manually set IP to 192.168.1.10 and gateway to 192.168.1.1.

    Run Recovery Tool, browse to find RT firmware and upload.

    Wait for 5 – 10 mins.

    Reboot when instructed to.

    • This reply was modified 1 year, 9 months ago by Six.
    #1877
    Six
    Participant
    • Posts 54
    • UKTechHub Regular

    Part Two:

    Connect to the router which at this point will still identify as DSL-AC68U despite running RT-AC68U firmware.

    Goto Administation>System and enable Telnet.

    Telnet onto the router.

    Enter:

    nvram show

    Select the output and cut and paste it into a text document as a backup.

     

     

    #1878
    Six
    Participant
    • Posts 54
    • UKTechHub Regular

    Part Three:

    Find the entry for cfg_device_list and copy the MAC Address and replace in both instances of XX:XX:XX:XX:XX:XX below

    Replace XXXX with the last 4 digits of the Mac Address

    Enter:

    nvram set cfg_device_list=”<RT-AC68U>192.168.1.1>XX:XX:XX:XX:XX:XX>0″
    nvram set dms_friendly_name=”RT-AC68U-XXXX″
    nvram set computer_name=”RT-AC68U-XXXX″
    nvram set productid=”RT-AC68U”
    nvram set lld2d_hostname=”RT-AC68U”
    nvram set asus_device_list=”<3>RTAC68U>192.168.1.1>XX:XX:XX:XX:XX:XX>0>asus>255.255.255.0>1″
    nvram set wps_modelnum=”RT-AC68U”
    nvram set daapd_friendly_name=”RT-AC68U-XXXX″
    nvram set wps_device_name=”RT-AC68U”
    nvram set odmpid=”RT-AC68U”

    nvram commit

    Then reboot your router, it should now identify as an RT-AC68U and allow you to select the option to use it as an AiMesh Node.

     

    • This reply was modified 1 year, 9 months ago by Six.
    #1879
    Six
    Participant
    • Posts 54
    • UKTechHub Regular

    Guess it doesn’t like long posts.

    #1882
    UK Sentinel
    Moderator
    • Posts 2181
    • UKTechHub Skipper

    Guess it doesn’t like long posts.

    Yes, xxxxx is a struggle sometimes (but designed to stop spammers inserting very long messages or sql injection type attack’s which I am plagued with at the moment from China and Ukraine), thanks for steps and hopefully all good your end ;-)

    In a completely sane world, madness is the only freedom (J.G.Ballard).

    #1886
    Six
    Participant
    • Posts 54
    • UKTechHub Regular

    OK this is not working at present, trying to find out why the nvram set commands won’t survive the AiMesh enabling reboot.

    • This reply was modified 1 year, 9 months ago by Six.
    #1888
    UK Sentinel
    Moderator
    • Posts 2181
    • UKTechHub Skipper

    OK this is not working at present, trying to find out why the nvram set commands won’t survive the AiMesh enabling reboot.

    Did you change the dms_friendly_name etc. to match you routers MAC Address last two octets ?

    Also, try ‘nvram+commit’  –  worth a try?

    In a completely sane world, madness is the only freedom (J.G.Ballard).

    #1891
    Six
    Participant
    • Posts 54
    • UKTechHub Regular

    Yes I caught the dms_friendly_name change, just didn’t change it in the posts yet.

    nvram+commit?

     

    #1893
    UK Sentinel
    Moderator
    • Posts 2181
    • UKTechHub Skipper

    Yes I caught the dms_friendly_name change, just didn’t change it in the posts yet. nvram+commit?

    Try ‘nvram+commit’ at the end rather than ‘nvram commit’ I noticed a few posts yesterday using this alternative?

    In a completely sane world, madness is the only freedom (J.G.Ballard).

    #1894
    Six
    Participant
    • Posts 54
    • UKTechHub Regular

    Finally done it. Need to work through the steps before I can share.

    AiMesh set up and running nicely.

    #1895
    UK Sentinel
    Moderator
    • Posts 2181
    • UKTechHub Skipper

    Finally done it. Need to work through the steps before I can share. AiMesh set up and running nicely.

     

    ;-)

    In a completely sane world, madness is the only freedom (J.G.Ballard).

    #1908
    UK Sentinel
    Moderator
    • Posts 2181
    • UKTechHub Skipper

    Note: backup original config as this maybe needed to convert back to DSL-AC68U if needed.

    I had a little play with my DSL-AC68U after flashing it with ASUS RT-AC68U Stock Firmware

    As above, I followed your steps 1 and 2 and then just entered the following commands via PUTTY (Telnet)

    nvram set odmpid=”RT-AC68U”

    nvram set asuscpeodmpid=”RT-AC68U”

    nvram set asuscpecommit=1

    nvram commit

    and hey presto, a DSL-AC68U that looks and acts as a True RT-AC68U with AiMesh (Node) option ;-)

    ———————

    UPDATE: Command should be………….

    nvram set odmpid=”RT-AC68U”

    nvram set asuscfeodmpid=”RT-AC68U”

    nvram set asuscfecommit=1

    nvram commit

    • This reply was modified 1 year, 8 months ago by UK Sentinel. Reason: Update Section Added

    In a completely sane world, madness is the only freedom (J.G.Ballard).

Viewing 15 posts - 1 through 15 (of 165 total)
  • You must be logged in to reply to this topic.