Enable AiMesh on ASUSWRT-Merlin (RMerlin)

Home Forums Wireless Routers & Modems ASUS ASUS (ASUSWRT-Merlin) Firmware (RMerlin) Enable AiMesh on ASUSWRT-Merlin (RMerlin)

This topic contains 37 replies, has 6 voices, and was last updated by UK Sentinel UK Sentinel 2 months, 3 weeks ago.

Viewing 15 posts - 1 through 15 (of 38 total)
  • Author
    Posts
  • #2141
    UK Sentinel
    UK Sentinel
    Moderator

    As some of you know all to well, ASUSWRT-Merlin as yet does not support AiMesh within his builds (officially)

    The below hack enables Aimesh on an ASUSWRT-Merlin flashed router

    Telnet to the router (RT-AC86U) flashed with Merlin fimrware and enter….

    nvram set amas_force=1
    nvram commit
    reboot

    Then the AiMesh should then appear in Routers UI πŸ˜‰

    Note: RMerlin has not enabled AiMesh within his builds for good reasons,Β  so if you decide to use this hack, then it is at your own risk. (totally)

    Note1: I have only tested this on my RT-AC86U, but seems to work well.

    In a completely sane world, madness is the only freedom (J.G.Ballard).

    #2303
    Grisu
    Grisu
    Participant

    your only problem will be to telnet to the router with Merlin as he stopped telnet-access over a year ago! πŸ˜‰

    But you can SSH instead …

    #2305
    UK Sentinel
    UK Sentinel
    Moderator

    your only problem will be to telnet to the router with Merlin as he stopped telnet-access over a year ago! πŸ˜‰ But you can SSH instead …

    Old habits die hard, “showing my age” πŸ˜‰

    In a completely sane world, madness is the only freedom (J.G.Ballard).

    #2900

    colgate1974
    Participant

    Thanks for this info. I’m looking to try this. I was wondering how this would be reversed if required?

    I ask because I know RMerlin hasn’t implemented because it potentially interferes with some of the custom features that he has implemented.

     

    Thanks again!

    #2901
    UK Sentinel
    UK Sentinel
    Moderator

    This command just allows AiProtection (I meant AiMesh) to be visible, as far as I am aware, RMerlin has not removed the Aimesh code, he has just elected not to show it due to possible coding compatibilities concerns. (and he is usually correct)

    I have seen a few posts that say Aimesh works with RMerlin, but it is not guaranteed.

    To reverse, just type…………

    nvram set amas_force=0
    nvram commit
    reboot

    I think that should work? if not before you run the initial command, take a backup of the config – just incase

    Let us know how it goes πŸ˜‰

     

    In a completely sane world, madness is the only freedom (J.G.Ballard).

    #2902

    colgate1974
    Participant

    Thanks for the SUPERFAST reply.

    I’ll let you know how it goes!

    #2903
    Grisu
    Grisu
    Participant

    before setting it to 1 get the recent value, “0” or none “” or variable not set at all.

    Then you can change back to original.

    nvram get amas_force

    Think it will be 0.

    In case no variable set to delete you could use “nvram unset amas_force”and nvram commit to save changes.

     

    @UK Sentinel: little correction, nothing to do with AiProtection!

    This command just allows AiProtection to be visible

    This command just allows AiMesh to be enabled

    • This reply was modified 3 months, 3 weeks ago by Grisu Grisu.
    #2905
    UK Sentinel
    UK Sentinel
    Moderator

    Thanks for spotting the mistake , yes should be AiMesh / not AiProtection, “typing on the Train” Β  πŸ˜‰

    In a completely sane world, madness is the only freedom (J.G.Ballard).

    #3084

    brianward317
    Participant

    I have this enabled and it’s working well.Β  However is there a way to easily update the 2nd nodes firmware?

    On the aimesh router, you can upload the firmware clicking the firmware button, but on the node, there is no option for this.

    I want to try and keep both nodes up to date.

    Only way I have been able to do it, is break the node, upload the firmware to the node, then rejoin it.

    #3085
    UK Sentinel
    UK Sentinel
    Moderator

    Take a look at these instructions

    https://www.asus.com/us/support/FAQ/1035199/

    Does this fix problem ?

    BTW – forgot to ask, what is the Primary Router (RT-DSL) etc ?

    In a completely sane world, madness is the only freedom (J.G.Ballard).

    #3086

    brianward317
    Participant

    No – I am running the merlin firmware, see screen shot

     

     

    Attachments:
    #3088
    UK Sentinel
    UK Sentinel
    Moderator

    Understood, I will have a look at mine tonight, hopefully @Six or @Grisu can also advise, but maybe not an automatic option with 2 x RMerlin based routers

    In a completely sane world, madness is the only freedom (J.G.Ballard).

    #3089

    brianward317
    Participant

    Understood – No worries at all.Β  I tried pressing the check update button, but it fails.Β  Only way to get it to update was to break the node off.Β  Factory reset it, upload it to the device, factory reset it and join the aimesh router.

    #3090
    Grisu
    Grisu
    Participant

    Aimesh nodes are updated on master router, added on update site for all routers.

    Merlin doesnt support Aimesh, so he wont show nodes to be updated.

    You can unmesh them for updates or change to asus stock for updating them.

     

    Dont have Asus anymore and forgot almost everything πŸ˜‰

    You could try to directly access update page for nodes, go to update on main router and change only IP part of the url to get there.

    • This reply was modified 3 months, 1 week ago by Grisu Grisu.
    #3093
    UK Sentinel
    UK Sentinel
    Moderator

    I was thinking, it looks like your Primary RT-AC3100 is also running RMerlin firmware, this is where I think the issue might be….

    Maybe an option to change Primary Router to ASUSWRT and then update option may work for AiMesh Node?

    Same sort of option as @Grisu was saying, but leaves Primary as ASUSWRT rather than RMerlin ?

    Update: – Always good to have a volunteer for testingΒ  πŸ˜‰

    In a completely sane world, madness is the only freedom (J.G.Ballard).

Viewing 15 posts - 1 through 15 (of 38 total)

You must be logged in to reply to this topic.