ASUS xDSL (PPPoE) Bridge Mode

Home Forums Wireless Routers & Modems … ASUS ASUS xDSL (PPPoE) Bridge Mode

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #357
    UK Sentinel
    Moderator
    • Posts 3412
    • Skipper

    ASUS xDSL (PPPoE) Bridge Mode

    Applies to the following xDSL Modem/Routers – is applicable for DSL-AC68U, DSL-N66U, DSL-N17U, DSL-AC56U, DSL-AC52U, and DSL-N16.

    PPPoE stands for Point-to-Point Protocol over Ethernet, a network protocol for encapsulating Point-to-Point Protocol (PPP) frames inside Ethernet frames. It is used mainly with DSL services where individual users connect to a DSL modem over Ethernet.

    ASUS xDSL Modem Router combos can be configured to operate in PPPoE Bridge Mode thus enables the ASUS device (Modem/Router) to act as a Modem only and allow other devices to connect directly to the PPPoE connection (router) and obtain the IP Address directly.

    To set your device to work in bridge mode, please go to WAN – Internet Connection.

    If you are using VDSL mode, please find your VLAN ID first. If 802.1Q is disabled, just ignore it. If 802.1Q is enabled, remember your VLAN ID, for instance 101.

    Now please:
    set “Service Unit” to “Bridge #1” (or any other you like)

    set “Enable” to “Yes”

    If you have VLAN ID:

    set “Enable” of 802.1Q to “Yes” and fill in the VLAN ID, for instance 101.

    And press “Apply” button.

    Then go to LAN – IPTV, please choose IPTV STB port, check “Remove VLAN TAG from WAN” option, and press “Apply”.

    Now go to your LAN client, and try to dial with your PPPoE account/password, you will get a public IP.

    In a completely sane world, madness is the only freedom (J.G.Ballard).

    #12505
    Lax
    Participant
    • Posts 11
    • Regular

    Sorry for reviving this old thread. I tried to put my DSL-AC68U to bridge mode. However, the option is not there.

    I can only create a bridge for IPTV.

    But not for the internet connection where the client does the pppoe authentication.

    Can anyone confirm this?

    #12506
    UK Sentinel
    Moderator
    • Posts 3412
    • Skipper

    Bridge mode for DSL-AC68U was removed a while back I believe.

    Try  PPPoE Relay is enabled ?

    WAN > NAT Pass through

    In a completely sane world, madness is the only freedom (J.G.Ballard).

    #12507
    Lax
    Participant
    • Posts 11
    • Regular

    Hmm, they still advertise this for dsl-ac68u on their support page.

    https://www.asus.com/support/FAQ/1015722/

    My ISP doesn’t let me connect with more than 1 client. So relay is out of question.

    I have found another workaround though. It just is not ideal and I don’t want to use it.

    In IPTV settings you can strip vlan tag with that checkbox “Remove VLAN tag from WAN” then select a port. Connect your router to that port. Then create a bridge IPTV connection from WAN, internet connection. Remove the internet connection such that only bridge IPTV remains.

    After that, your router takes it over. But it just is not transparent enough for me to see what is going on. So, I cannot trust it.

    • This reply was modified 4 months ago by Lax.
    #12509
    UK Sentinel
    Moderator
    • Posts 3412
    • Skipper

    I did load the latest firmware for the DSL-AC68U – DSL-AC68U-300438641995 – and the Bridge mode option was not available.

    On your DSL-AC68U – under WAN remove the PPPoE Account Authentication and password detail and then that may allow you to connect another router / device and use ISP authentication there ?

     

    In a completely sane world, madness is the only freedom (J.G.Ballard).

    #12512
    Lax
    Participant
    • Posts 11
    • Regular

    Yeah, I will try that and see how it will handle it but without bridging dsl modem I would be a pride owner of shiny new double NAT.

    I guess DMZing my router IP can fix that. Though, I am not sure what would be the implications.

    #12514
    UK Sentinel
    Moderator
    • Posts 3412
    • Skipper

    I believe PPPoE Relay does not use NAT as the PPPoE device will get its own IP adddress etc

    In a completely sane world, madness is the only freedom (J.G.Ballard).

    #12522
    Lax
    Participant
    • Posts 11
    • Regular

    Nope, I have to use NAT with ac68u with pppoe relay because, I need to identify the dsl interface using ac68u with Vlan ID because my ISP uses 802.1Q.

    I have a rt-ac5300 behind dsl-ac68u and I cannot set Vlan ID with rt-ac5300. There is no 802.1Q setting on the ac5300 router.

    Disabling NAT on the WAN/Internet Connections on AC68U doesn’t help either because I lose internet connection with NAT disabled.

    Here is what I did.

    On AC68U,

    I enabled PPPoE relay.

    Connected LAN 1 of AC68U to WAN of RT-AC5300

    Changed the IP address of AC68U to 192.168.0.1 (using similar DHCP range)

    On DHCP server I assigned a static IP to RT-AC5300 WAN MAC so it is easy to access.

    AC68U WAN settings are attached.

    I had to use automatic IP here but I don’t know how correct it is. Any idea?

    AC5300 WAN settings are attached.

    According to logic I should be behind double NAT. However, I checked and apparently I am not. Well, at least I can access my devices just fine without any port forwarding on the ac68u.

    Also, I get the attached warning message on the DSL-AC68U GUI with these settings.

    “Your ISP’s DHCP does not function properly.”

    #12526
    UK Sentinel
    Moderator
    • Posts 3412
    • Skipper

    Great news in that you now not having double NAT issues and hopefully all working well

    In a completely sane world, madness is the only freedom (J.G.Ballard).

    #12530
    Lax
    Participant
    • Posts 11
    • Regular

    Yeah, thanks for helping out and clarifying things. Asus faq site was misleading me.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.
UKTechHub.com