Latest Beta Firmwares for DSL-AC51 to DSL-N66U incl. DSL-AC750

Home Forums Wireless Routers & Modems ASUS Latest Beta Firmwares for DSL-AC51 to DSL-N66U incl. DSL-AC750

This topic contains 103 replies, has 18 voices, and was last updated by UK Sentinel UK Sentinel 1 week, 4 days ago.

Viewing 15 posts - 1 through 15 (of 104 total)
  • Author
    Posts
  • #390
    UK Sentinel
    UK Sentinel
    Moderator

    Latest DSL ASUSWRT firmware v9.1.2.3_502-g2bdb05b now available. (latest firmware’s are at end of threads)

    For following ASUS DSL Modem Routers:

    DSL-AC51

    DSL-AC52U

    DSL-AC55U

    DSL-AC56U

    DSL-AC750

    DSL-N10-C1

    DSL-N12E-C1

    DSL-N12U-C1

    DSL-N12U-D1

    DSL-N14U

    DSL-N14U-B1

    DSL-N16

    DSL-N16U

    DSL-N17U

    DSL-N55U-C1

    DSL-N55U-D1

    DSL-N66U

     

    https://www.asuswebstorage.com/navigate/s/7E4C665AF3BD431DA086190A55796D24Y

    – [MT751x] xDSL driver updated: v5.5.2.10.

    – [MT751x] Fixed kl0 calculation error leads to UPBO Tx drop and affected Upstream synced data rate with certain DSLAM issue.

    – Fixed possible cfg_manager stuck issue, leads to UI access failure.

    – Fixed the issue with the unsaved LAN setting caused by cfg_manager broken pipe.

    – Fixed possible Boa web server initiating failed due to missing some default attributes issue.

    – Fixed upload Settings file via IE11 would fail issue.

    – Fine tune FAQ link.

    – Fine tune QoS default rule list.

    – Fixed various UI related issues.

    – VDSL WAN (PTM) QIS manual setting list updated,

    Added Australia ISP Aussie Broadband.
    Added Australia ISP Buzz Telco.
    Added Australia ISP MyRepublic.

    UK Sentinel

    • This topic was modified 1 year, 1 month ago by UK Sentinel UK Sentinel.

    In a completely sane world, madness is the only freedom (J.G.Ballard).

    #435

    babis3g
    Participant

    Latest beta DSL ASUSWRT firmware v9.1.2.3_552

    (choose your mediatek model from the link below)

     

    https://www.asuswebstorage.com/navigate/s/949DB438AF874241AF0571590B399543Y

    – For MT7510 built-in FE switch models, added more switch buffer in order to cache the burst from WiFi side, WiFi throughput enhancement.
    – For MT7612E based models, improve the retry mechanism when the key is exchanged, adopted possible fix for 5GHz SSID could not be discovered issue.
    – Fixed Command Execution security vulnerability issue. However, this issue considered as minor as the vulnerability cannot be remotely exploited and requires a valid authentication. Adopted whitelist checking.
    – MT7612E WiFi driver updated: MT7612E_LinuxAP_3.0.4.0.P2_DPA.
    – Fixed possible power cycle leads to romfile extraction hang issue(rare case), adopted new gzip/gunzip.
    – Fixed IPTV configuration in disable_other_wan case.
    – Fixed UI related issues.
    – VDSL WAN (PTM) QIS manual setting list updated,
    Add Switzerland ISP Swisscom, Automatic IP, VLAN ID 10.

    • This reply was modified 1 year, 1 month ago by  babis3g.
    #483

    babis3g
    Participant

    DSL ASUSWRT <span lang=”EN-US”>v9.1.2.3_576-gebbda6c</span> beta firmware now available, mainly with 2.4GHz throughput enhancement(for MT751x/MT7592 based models).

    Sorry not full changelog for now

    Download the correct firmware for your model, link below

    https://www.asuswebstorage.com/navigate/s/775DCC78A21044B88D8A5A3B98CB4909Y

    Many thanks

    • This reply was modified 1 year, 1 month ago by  babis3g.
    #485
    UK Sentinel
    UK Sentinel
    Moderator

    Thanks Babis3g as always ;-)

    In a completely sane world, madness is the only freedom (J.G.Ballard).

    #1256
    UK Sentinel
    UK Sentinel
    Moderator

    Latest DSL ASUSWRT Beta firmware v9.1.2.3_605-gca8dee5 now available.

    Changelog to follow when ASUS get round to it ;)

     

    Edit: spoke with ASUS and changelog should be available next week

     

    v9.1.2.3_605-gca8dee5

    https://www.asuswebstorage.com/navigate/s/4AA545DA7C92452CA8B22F476A382191Y

    as always, this is a beta, please see sticky at top of this forum –  (ASUS DSL Beta Firmware Policy / Usage Understanding Guidance)

    UK Sentinel

    In a completely sane world, madness is the only freedom (J.G.Ballard).

    #1349
    Damis
    Damis
    Participant

    I am curious about the changelog.

    I had issues with strange dropouts of LAN ports with previous firmware. It appears it’s gone now, but I can’t confirm it because it seems that I can’t scroll up in System Log (go back in time)? I suppose that’s a bug?

     

    Current firmware: v9.1.2.3_605-gca8dee5

    Previous firmware: v9.1.2.3_576-gebbda6c

    #1350
    UK Sentinel
    UK Sentinel
    Moderator

    I am curious about the changelog. I had issues with strange dropouts of LAN ports with previous firmware. It appears it’s gone now, but I can’t confirm it because it seems that I can’t scroll up in System Log (go back in time)? I suppose that’s a bug? Current firmware: v9.1.2.3_605-gca8dee5 Previous firmware: v9.1.2.3_576-gebbda6c

    That is odd, so you are saying with latest firmware, the scroll option does not work?, can you remind me which DSL router you have as I can then pass this back to ASUS?

    In a completely sane world, madness is the only freedom (J.G.Ballard).

    #1352
    Damis
    Damis
    Participant

    DSL-AC55U

    I checked it again. The scrollbar at the side isn’t present at all and the mouse wheel also doesn´t work. The separate log lines get pushed up by new ones and when they go beyond the frame you can’t scroll up to view them.

    PS: I did not make a factory reset this time, but I don’t think this could have any relation to it

    #1353
    UK Sentinel
    UK Sentinel
    Moderator

    DSL-AC55U I checked it again. The scrollbar at the side isn’t present at all and the mouse wheel also doesn´t work. The separate log lines get pushed up by new ones and when they go beyond the frame you can’t scroll up to view them. PS: I did not make a factory reset this time, but I don’t think this could have any relation to it

    Understood and thanks for details, I have a DSL-AC56U and will see if the same happens also with the latest firmware.

     

    In a completely sane world, madness is the only freedom (J.G.Ballard).

    #1354
    UK Sentinel
    UK Sentinel
    Moderator

    @Damis – I loaded the latest beta firmware (v9.1.2.3_605-gca8dee5) from my DSL-AC56U and rebooted router, the System Log > General Log scroll to the right works on my unit, I also tried a couple of other browsers (Edge / Chrome) and that they also worked.

    Maybe worth trying a different browser, just to check if bug, if not the alas you need to try a factory reset to see if this fixes issue? if this fails to fix issue then a bug is very likely and we can feed this back to ASUS.

    (FYI – DSL-AC56U and DSL-AC55U firmware’s are very similar)

     

    • This reply was modified 11 months, 2 weeks ago by UK Sentinel UK Sentinel.

    In a completely sane world, madness is the only freedom (J.G.Ballard).

    #1358
    Damis
    Damis
    Participant

    I proceeded with a router reboot and System Log is working correctly now. Sorry to bother you.

    #1359
    UK Sentinel
    UK Sentinel
    Moderator

    I proceeded with a router reboot and System Log is working correctly now. Sorry to bother you.

    ;) no problem

    In a completely sane world, madness is the only freedom (J.G.Ballard).

    #1467
    UK Sentinel
    UK Sentinel
    Moderator

    Latest DSL ASUSWRT v9.1.2.3_617 download link/ change log as follows.

    (and a changelog this time) ;-)

     

    v9.1.2.3_617-gfa1b634

    https://www.asuswebstorage.com/navigate/s/FD6779114D6641B8A78A7A0B4571AB22Y

     

    –  When Watch Dog Enabled in DUAL WAN, if target does not fill in proper value, it will cause the wanduck ping to fail. This leads to do_ping_detect returns fail, resulting in continuous failback.
    – Fixed when applying DSL Setting > ISP Specific Setting, it failed to take effect issue.
    – Fixed set LAN port as Ethernet WAN unable to execute Chariot / Iperf test issue.
    – Fixed UI access slow/ Speedtest no result, under LAN as Ethernet WAN mode issue.
    – AiCloud updated:  v2.0.2.8.
    – Set the value of Fragmentation threshold to check that packet fragmentation does not take effect. Fixed Wi-Fi Tx function, the ICMP packet type is set incorrectly.
    – Fixed 5GHz connection rate drop from 780Mbps to between 54Mbps – 173Mbps issue.
    – Wifi long-term mount test, STA scans less than AP’s SSID issue.
    – Fixed the 5GHz band isn’t working after turning off and on both/or 2.4GHz/5Ghz band via Router app.
    – Fixed applying wrong DSL setting by wrong attribute for ADSL/VDSL mode.
    – [MT7592] WiFi driver updated.
    – KRACK patch: WPA2 security vulnerability issue(When the AP receives a retransmitted Message 2/4, it should check the WPA2 processing state. AP should ignore the Message 2/4 if the WPA2 security connection is done). Earlier KRACK patch specifically for ApClient/STA, now later paper by Mathy Vanhoef targets AP, thus need to adopt this additional patch.
    – Fixed ISP_DHCP_Opt_List.txt parse error.
    – Fixed various UI related issues.
    – ADSL WAN (ATM) QIS manual setting list updated.
    – Add Turkey ISP TTNET/ D-Smart Net(Smile ADSL)/ Doping/ Turkcell Superonline, ADSL+IPTV services.

     

    • This reply was modified 11 months, 1 week ago by UK Sentinel UK Sentinel.

    In a completely sane world, madness is the only freedom (J.G.Ballard).

    #1662

    ampthetex
    Participant

    Hi, I was wondering if you can help me out at all. I have Sky Fibre, I want to use my DSL-N66U with, it works with the last standard firmware from ASUS, and connects via its own on setup no problem, but the wifi is rubbish and keeps dropping out. Ive used the last two betas, the wifi is perfect but I cant for the life of me get the damn thing to connect. I used the beta versions with my old sky broadband before fibre, and it was perfect. When I reflash it with the last 2 betas it just says initialising…………then X and Link down. Whats been left out or changed between the original firmware and the betas that just doesnt want me to connect. When I go into setup wizard Ive chosen Sky, etc. Nothing

     

    These are the betas

    DSL-N66U_v9.1.2.3_502-g2bdb05b

    DSL-N66U_v9.1.2.3_617-gfa1b634

    Thanks in advance

    Steve

    #1664
    UK Sentinel
    UK Sentinel
    Moderator

    A couple of suggestions, When you flash the latest beta, do you perform a factory reset afterwards and then configure from scratch or load a pre-saved settings file? if you load a back-up, try to build/configure from scratch.

    Is there any error messages in the system log, the DSL-N66U is an old unit, so not sure what messages are shown, if any?

    In a completely sane world, madness is the only freedom (J.G.Ballard).

Viewing 15 posts - 1 through 15 (of 104 total)

You must be logged in to reply to this topic.